Sign in to follow this  
Guest DJ Mattzzka

RenderAheadLimit

Recommended Posts

Guest DJ Mattzzka

es que c'est le RenderAheadLimit svp je me demande, defaut il est sur 2

et je met sur quelle chiffre

Share this post


Link to post
Share on other sites

Je l'ai mis à zéro depuis qu'il est dispo sur la beta et comparé à la valeur par défaut (2), le jeu me semble plus fluide. Niveau FPS j'ai du gagné deux, trois frames mais c'est surtout lors des explosions et quand il y a beaucoup de fumée que la différence se ressent.

Share this post


Link to post
Share on other sites

Le "RenderAheadLimit" est une fonction qui limite le nombre d'images que pré calcule par avance le CPU avant de les envoyer à la carte graphique pour traitement, car dans certains cas, cela génère du freeze d'images, voir lag permanent, voir même plantages du client.

à 0 le CPU pré calcule un max d'image, et plus le paramètre monte, plus le nombre d'image pré calculées est petit.

Ainsi en fonction de la config :

- si le CPU est légèrement surpuissant par rapport à la CG, il faut monter le chiffre de ce paramètre (vers 2, 3, 4 ou 5) : (genre un i7-950 avec une GT8800 : il faut le mettre à 5)

- si le CPU est légèrement en sous capacité par rapport à la CG (genre un 6600 avec une HD5870), il faut le mettre à 0

En clair si vous n'avez pas de lag ou plutôt de freeze d'images réguliers et que le FPS ne fait pas de yoyo, mettez le à 0

si le FPS fait du yoyo (même sur une grosse config) genre 120 en crête mais avec des chuttes à 60 dans certains cas, mettez le RenderAheadLimit à 2 ou à 3 (faites des tests) : ça diminue les crêtes de FPS un peu mais stabilise son niveau en moyenne.

Share this post


Link to post
Share on other sites

Voila qui est intéressant, merci louloo pour les explication; par contre où modifie t-on ce paramètre?

Merci.

C'est clair, merci pour l'éclairage ! Sinon ça se modifie dans le fichier setting.

Share this post


Link to post
Share on other sites

Voila qui est intéressant, merci louloo pour les explication; par contre où modifie t-on ce paramètre?

Merci.

Je pense que tu peux le faire avec le Gossamer's Bad Company 2

Merci des explication, je vais allez toute suite réglé ça sur 0 vu que ma configuration et encore trop basique.

Raiden

Share this post


Link to post
Share on other sites

Je pense que tu peux le faire avec le Gossamer's Bad Company 2

ATTENTION :

à moins que la dernière version l'ai intégré (je ne peux pas vérifier, je suis au taf), au début cet outil modifiait par erreur le renderaheadlimit lorsqu'on modifiait le "view distance" de l'outil.... et mettait ainsi un 10 en valeur au renderaheadlimit ce qui avait pour effet de faire planter le client...... donc mef

mieux vaut aller manuellement éditer manuellement le fichier "settings.ini" qui se trouve dans "Mes Documents/BFBC2"..... ;)

Share this post


Link to post
Share on other sites

Tu en avais déjà parlé louloo non?!

Merci je vais devoir faire des essais, très certainement mettre 0, a voir.

Par défaut il est à 2 si je ne me trompe (je ne suis pas chez moi pour vérifier).

Share this post


Link to post
Share on other sites
Guest DJ Mattzzka

bon en gros je suis sur un pc portable

AMD Turrion II M500 2.20 GHz ATI Radeon 4650 HD

il faut mettre sur 0 c'est ça

Share this post


Link to post
Share on other sites

Voila qui est intéressant, merci louloo pour les explication; par contre où modifie t-on ce paramètre?

Merci.

Tu peut le modifier en allant dans : Documents/BFBC2/settings.ini. Tu ouvre donc le settings.ini est tu change la valeur du RenderAheadLimit puis tu ferme en enregistrant ;)

Share this post


Link to post
Share on other sites

Tu en avais déjà parlé louloo non?!

oui lors d'un patch de la béta, lorsqu'ils ont sorti le paramètre pour corriger certains problèmes de lag justement sur les grosses configs.

bon en gros je suis sur un pc portable

AMD Turrion II M500 2.20 GHz ATI Radeon 4650 HD

il faut mettre sur 0 c'est ça

si tu n'as pas de problèmes, ne touche pas. ;)

Share this post


Link to post
Share on other sites
Guest DJ Mattzzka

oui lors d'un patch de la béta, lorsqu'ils ont sorti le paramètre pour corriger certains problèmes de lag justement sur les grosses configs.

si tu n'as pas de problèmes, ne touche pas. ;)

probleme de lag etc si un peu

Share this post


Link to post
Share on other sites

probleme de lag etc si un peu

pas sur que ton lag vienne de là.. il peut aussi venir de ta ligne, si tu joue en wifi vu que c'est un portable...etc...

mais si tu veux en avoir le cœur net, essaie entre 0 et 3

Share this post


Link to post
Share on other sites
Guest DJ Mattzzka

pas sur que ton lag vienne de là.. il peut aussi venir de ta ligne, si tu joue en wifi vu que c'est un portable...etc...

mais si tu veux en avoir le cœur net, essaie entre 0 et 3

ok merci mais je joue pas en wifi

Share this post


Link to post
Share on other sites
Guest DJ Mattzzka

Le mien était à 2, je l'ai mit à 0 je vais voir ce que ça donne.

alors ça change ou pas stp

Share this post


Link to post
Share on other sites

Eh bien je dirai que vu mon config puissant, je ne laggais pas à 2, et à 0 je ne lag pas non plus.

Je laisse un peu plus mon CPU travailler, en DX11 tout à fond je suis à 90FPS environ en pleine action.

Share this post


Link to post
Share on other sites

Salut, Je suis sous Windows 7 et losrque je vais sous nomdel'ordi/document/BBC2 je ne trouve pas le dossier setting.ini. j'en trouve 2, dont le nom contient setting dedans, je ne trouve pas de mot Render...

Donc svp aider moi !!

PS: j'ai 2 GO de memoire vive, j'ai fait une maj de ma cg aujourd'hui meme et je lag tjr autant !

Merci De votre aide

Share this post


Link to post
Share on other sites

je comprend pas trop mon fichier game settings :

RenderAheadLimit[GstAudio]

DialogueVolume=0.870000

CarRadio=1

VoipEnable=0

OriginalVOForEnemyTeam=1

MusicVolume=1.000000

VoipPushkey=1

SoundSystemSize=3

...

Comment je fais pour modifier la valeur ? :blink:

Share this post


Link to post
Share on other sites

normal !!!

c est dans le fichier "Settings.ini" et non le "GameSettings.ini"

C:\Users\ta session\Documents\BFBC2\settings.ini

Share this post


Link to post
Share on other sites

J'ai un processeur AMD Phenom II x4 955 et une HD 5850.

Par défaut mon RenderAheadLimit était à 2 et je tourner à 60-50 fps.

J'ai mit le RenderAheadLimit à 0 et j'ai trouver que je freezer beaucoup. 40fps en moyenne. Alors j'ai remit à 2

Share this post


Link to post
Share on other sites

J'ai un processeur AMD Phenom II x4 955 et une HD 5850.

Par défaut mon RenderAheadLimit était à 2 et je tourner à 60-50 fps.

J'ai mit le RenderAheadLimit à 0 et j'ai trouver que je freezer beaucoup. 40fps en moyenne. Alors j'ai remit à 2

et si tu passes au dessus des "2" ???

Share this post


Link to post
Share on other sites

J'ai tester vite fait avec une valeur de 5. j'ai pas vu de grosses différences...

C'est censé faire quoi si j'ai une trop grosse valeur ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this