Sign in to follow this  
bifone

[Résolu]Plantage en ligne temps aléatoire

Recommended Posts

salut,

j ai cherché dans les différents post du forum et sur plein d autres d'ailleurs mais je ne trouve pas la solution à mon problème.

tout d'abord voici ma config:

Operating System: Windows 7 Édition Intégrale 64-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)

System Manufacturer: Acer

System Model: Aspire M3201

BIOS: Default System BIOS

Processor: AMD Phenom 9550 Quad-Core Processor (4 CPUs), ~2.2GHz

Memory: 4096MB RAM

Available OS Memory: 3840MB RAM

Page File: 1661MB used, 6014MB available

DirectX Version: DirectX 11

---------------

Display Devices

---------------

Card name: ATI Radeon HD 3600 Series

Manufacturer: ATI Technologies Inc.

Chip type: ATI display adapter (0x9598)

DAC type: Internal DAC(400MHz)

Display Memory: 2169 MB

Dedicated Memory: 506 MB

Shared Memory: 1663 MB

Current Mode: 1440 x 900 (32 bit) (60Hz)

Monitor Name: Generic PnP Monitor

Monitor Model: LE1940

Monitor Id: BTC1940

Native Mode: 1440 x 900(p) (60.070Hz)

Output Type: HD15

Driver Name: aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atiumdag,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll

Driver File Version: 8.17.0010.0024 (English)

Driver Version: 8.732.0.0

DDI Version: 10.1

Driver Model: WDDM 1.1

Driver Attributes: Final Retail

Driver Date/Size: 5/5/2010 10:18:36, 584704 bytes

------------

DxDiag Notes

------------

Display Tab 1: No problems found.

Sound Tab 1: No problems found.

Sound Tab 2: No problems found.

Input Tab: No problems found.

donc mon problème est le suivant, je lance le jeu (Battlefield 2)il démarre impeccable je choisi un serveur nikel il charge et j'entre en jeu, je joue un moment et hop retour Windows. parfois au bout de 10 sc parfois 5 mn. j'ai essayé plein d'astuces trouvé sur les différents forum mais aucun ne règle mon souci.

si quelqu'un pouvais m'aider ca serait bien cool.

merci d'avance pour vos infos.

Share this post


Link to post
Share on other sites

salut oui mes pilotes sont bien à jour (version 10.8 du 04/08/2010), c'est la première chose que j'ai faite quand mon problème à commencé.

Comme je l'ai dit il s'agit du jeu (Battlefield 2, vieux mais toujours très amusant pour ma part ^^)

Share this post


Link to post
Share on other sites

bonjour

les options en jeu ont une résolution de 1024X768 en 60 Hz et il n'y as pas dans le menu déroulant la résolution de mon écran (a savoir 1440X900 )

j'ai lu sur un forum d'ajouter la résolution dans les propriétés du raccourci, à la suite de "D:\Program Files\EA GAMES\Battlefield 2\BF2.exe" +playNow 1 +menu 1 +fullscreen 1 et y ajouter ça +szx 1440 +szy 900, j'ai essayé mais cela plante quand même.

Share this post


Link to post
Share on other sites

2 possibilités ...

soit le DirectX ... soit le son !!!

peut etre qu un parametre du son (type emulation EAX) qui ferait planter le jeu ...

mais la possibilité qu un composant du Dx ne soit pas a jour fait aussi planter le jeu aussi ...

a voir ...

Share this post


Link to post
Share on other sites

salut et merci de vous pencher sur mon problème ;)

donc en ce qui concerne DX il est a jour avec DX11 et je laisse bien le jeu installer son DX9c.

Pour le son c'est une piste a approfondir je pense car récemment pour utiliser Audacity (un logiciel de capture de son etc...) j'ai du installer des pilotes hd audio Realtek sinon le logiciel ne pouvais pas trouver les son ma carte n'était pas détecté par le logiciel. suite a une recherche sur Google, j ai vu qu'il suffisait d'installer ces pilotes pour que cela marche. je vais voir du coté de ma carte son si des pilote peuvent être plus récent.

pour ce qui est de l'émulation EAX j'ai décoché la case dans les option de jeu et j ai mis la qualité moyenne basse pour essayer car a un moment des que je changer la hauteur de mon volume le jeu ce fermé.

Share this post


Link to post
Share on other sites

donc je viens de désactiver le pilote de realtek, désactiver le EAX mis en prise en charge matériel puis logiciel le tout en qualité moyenne et ça plante toujours

Share this post


Link to post
Share on other sites

bonjour

les options en jeu ont une résolution de 1024X768 en 60 Hz et il n'y as pas dans le menu déroulant la résolution de mon écran (a savoir 1440X900 )

j'ai lu sur un forum d'ajouter la résolution dans les propriétés du raccourci, à la suite de "D:\Program Files\EA GAMES\Battlefield 2\BF2.exe" +playNow 1 +menu 1 +fullscreen 1 et y ajouter ça +szx 1440 +szy 900, j'ai essayé mais cela plante quand même.

La déjà il y a un problème, car depuis le dernier patch cette manipe ne sers plus a rien car normalement il y a ta résolution, j'y suis moi avec mon portable ! Tu as bien mis le dernier patch au moins !

Share this post


Link to post
Share on other sites

salut,

heu non je n ai pas mis de patch. le jeu est en 1.0.2442.0

j ai voulu mettre les patch mais je ne suis pas sur que de mettre le 1.41 directement fonctionne. j'ai lu que je devais appliquer les patch successif, mais je ne sais pas l'ordre des patch a installer.

Share this post


Link to post
Share on other sites

Il faut mettre le 1.41 puis le 1.5 ! Tu trouveras plus de serveur dans cette version, de plus tu auras plus de map étant donné que le patch inclus les maps des Extensions et tu pourras en plus mettre ta résolution et qui c'est ça va peut-être résoudre ton probleme ! Donc que du bonheur ! :P

Share this post


Link to post
Share on other sites

salut, donc j ai téléchargé les patch 1.41 installé puis le 1.50 installé.

mais là c'est la cata ^^ je lance le jeu, écran noir comme si il allait s'ouvrir, puis retour bureau ^^ je peux meme plus l'ouvrir lol.

Share this post


Link to post
Share on other sites

salut, donc j ai téléchargé les patch 1.41 installé puis le 1.50 installé.

mais là c'est la cata ^^ je lance le jeu, écran noir comme si il allait s'ouvrir, puis retour bureau ^^ je peux meme plus l'ouvrir lol.

alors ...

je pense qu on y est !!!

je suis presque sur que c est le Dx ... donc tu telecharges le "Dxwebsetup.exe"

et tu le lances pour faire une MaJ

il va certainement trouver des petites choses a mettre a jour !!!

pour ce qui du Dx il faut savoir que ce nest pas parce qu on a la derniere version , qu on est a jour

chaque jeux utilisent des ".dll" qui ne s installent que si le jeu est installé ...

donc si tu as mis a jour ton Dx puis que tu as installé ton jeu ... il faut relancer une MaJ du Dx

apres l installation du jeu ...

Share this post


Link to post
Share on other sites

salut et merci pour ta réponse.

donc j ai téléchargé "Dxwebsetup.exe" il a trouvé effectivement des maj facultative et autre. par contre le jeu ne démarre toujours pas. fenêtre noire puis retour bureau.

Misère misère

Share this post


Link to post
Share on other sites

bon finalement, j'ai supprimé le Bf2.exe et j ai relancé la maj DE 1.41_vers_1.50 et maintenant ca marche le jeu démarre, il reconnait ma définition d'écran, nickel. il semble ne plus planté . mais je n'en suis pas sur car je reçoit un message de punkbuster me disant que j ai été kick du serveur ^^ et certains serveur me dise que ma clé n'est pas valide ^^

donc c'est pas loin d'être nickel mais reste un problème ^^

Share this post


Link to post
Share on other sites

bon finalement, j'ai supprimé le Bf2.exe et j ai relancé la maj DE 1.41_vers_1.50 et maintenant ca marche le jeu démarre, il reconnait ma définition d'écran, nickel. il semble ne plus planté . mais je n'en suis pas sur car je reçoit un message de punkbuster me disant que j ai été kick du serveur ^^ et certains serveur me dise que ma clé n'est pas valide ^^

donc c'est pas loin d'être nickel mais reste un problème ^^

pour l histoire de la clef non valide il me semble qu il faut aller dans le registre et controler l' "ergc"

verifier que le serial commence bien par "x9392..."

pas la version du serial classique mais la version en Hexadecimal ...

Share this post


Link to post
Share on other sites

donc pour la cle invalide utilisez le bf2_ code qui est dans le dossier :

C:\Program Files\EA GAMES\Battlefield 2\Support\Battlefield 2_code.exe

entrez votre clé puis appliquer ce fix

http://perso.wanadoo.fr/amd.burner/BF2/BF2CDKeyCheck.rar

du coup ma clé est valide, le jeu plante plus, N I C K E L

merci pour votre aide et j'espère que cela servira à d'autres.

Share this post


Link to post
Share on other sites

Bonjour,

Content que tu aies résolu ton problème principal. :)

Je me permets de locker comme le souci est résolu. ;)

Bonne journée smile.gif

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this