Sign in to follow this  
Spb8

Javascript qui ne fonctionne pas sur les dernières images (slide)

Recommended Posts

Salut à tous, tout d'abord, bravo pour ce site qui est très agréable !

Mais ... y'a encore quelques petits défauts de jeunesse, normal au lancement :)

Alors, sur la page d'accueil, il y en bas à droite (http://www.bf-france.com/#news2_1b) un slide des dernières images qui est proposé.

Si je clique sur le numéro 2 (je pense que ça devrait afficher la suite des dernières images), bah, ça ne fait rien du tout.

Ensuite, je ne sais pas si vous êtes fanas de l'accessibilité, mais moi oui, et niveau validation structurel du site, c'est pas ça (144 erreurs syntaxiques), dont beaucoup car les ID des balises sont réutilisés alors qu'ils devraient être uniques.

Au niveau sémantique, c'est pas ça non plus, vous utilisez les Titre Hx pour de la présentation, et il y a des trous :

Plan du code ci dessous :

<h1>
     <h2>
          <h3>
               <h4>
                    <h5>
                         <h6>

Plan du document - http://www.bf-france.com/

A La Une
     [Titre manquant]
          BIENVENUE SOLDAT !
          BF1943 : TRAILER 1
          REJOINS-NOUS !
          GALERIE BF 1943
          BIENVENUE SOLDAT !

Messages du forum

Actualité Evènement
     [Titre manquant]
          [Titre manquant]
               Bienvenue sur BF-France !

Actualité BF en continue
     [Titre manquant]
          [Titre manquant]
               Le plein de vidéos et d'images !
               Annonce de Battlefield Bad Company 2
               Annonce de Battlefield 1943

Dernières Vidéos
     [Titre manquant]
          [Titre manquant]
               Bad Company 2 : Trailer
               GDC 09 : Battlefield 1943 Game Demo
               Présentation de BF 1943

Dernières Images

Menu

Annonces

Liens

     [Titre manquant]
          [Titre manquant]
               [Titre manquant]
                    [Titre manquant]
                         [Titre vide]
                              http://googleads.g.doubleclick.net/pagead/ads?client=ca-pub-2220095451874787
                              http://a.cca10.com/1138190057.html?r=http%3A//www.bf-france.com/forums/index.php%3Fact%3Dpost%26do%3Dnew_post%26f%3D8
                              http://static.criteo.com/empty.html

Il y a un bug avec les dates (que ce soit pour les citation, pour la date en bas à droite) :

Nous sommes le : %PM %01 %758 %2009 à %17:%Apr

Et ensuite pour finir pour ce soir, sur la page de présentation de battlefield 1943, vous indiquez :

Machines Concernées :

PC

C'est faut, il y a aussi la Xbox 360 dans le lot (PS3 je ne sais pas).

Merci de m'avoir lu :)

P.S : les smileys qui vont bien sur fond noir sont dispo pour vous, pourquoi ne pas les mettre en place pour donner encore plus de class à ce site ?

Share this post


Link to post
Share on other sites

Un vrai cordon bleu toi di donc.

Mais bon les sites qui propose le système de validation, il ne faut pas toujours les suivres... Surtout que généralement les problèmes survienne à causes des pubs.

Bref il y a des choses beaucoup plus importante. Malgré tout, keit regardera je pense. Sa n'empêche en rien une navigation correct sur le site sans erreur. Et ce n'est pas un site professionnel, ne t'y trompe pas ! Je préfère avoir des erreurs "conne" de codage et avoir du contenu que avoir 0 erreur et un contenu médiocre. Faut savoir viser un objectif, le staff à une vie extérieur aussi.

Pour ton problème de script, ceci provient d'une activation manquante, il a été testé chez différentes personnes et n'a aucun problème. Après reste à savoir quel navigateur tu utilise.

Pour tes petits soucis sur le forum, sa sera réglé, faut aussi nous laisser le temps comme je l'ai dit plus haut dans ce message.

Share this post


Link to post
Share on other sites

Merci pour ta réponse.

Je suis dans le même cas que toi, je suis bénévole, et pas professionnel, j'ai aussi une "vrai" vie bien remplie :)

Ce ne sont que des constats, après le site tourne, pas de soucis :)

Pour les informations sur moi :

Navigateur Firefox 3.0.8

Windows XP Pro SP3

Je viens de retester, et ça ne fonctionne toujours pas. (Le slide en bas du site)

Pour les erreurs, ce ne sont que des erreurs syntaxique du site, en aucun les frames des pub googles :) (Le site que j'ai mis en lien qui relate les erreurs syntaxique du code HTML est la validateur du W3C, rien de plus sérieux quand même :) )

La pluparts des erreurs sont des erreurs super simple à corriger (ne pas utiliser plus d'un ID, il faut remplacer les ID par des CLASS, et faire les changements adéquat dans le code CSS pour ne pas perturber l'affichage). Je pense que ça devrait corriger déjà 80 % des erreurs.

Je sais ce que c'est que la gestion d'un site, c'est très lourd. Donc je ne vous en voudrait vraiment pas de ne pas pouvoir tout faire tout de suite, car ce n'est pas le but de messages, juste d'avoir un oeil externe pour vous fournir un peu plus de travail :P

Encore bravo :)

Share this post


Link to post
Share on other sites

Le lien "Plus d'images" a été corrigé. Concernant le soucis de la page 2, je n'ai aucun problème sous Firefox 3.0.8 ou sur IE 8.

Et enfin, pour ce qui est de la validation W3C, ce n'est vraiment pas notre priorité. Si on a le temps, on s'en occupera. Le site fonctionne sur les principaux navigateurs, je ne vois donc pas l'utilité d'avoir une page valide, à part se plier à des pseudo-règles.

Merci en tout cas d'avoir remonté tout ça.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this