Sign in to follow this  
rG.fr

[BUG résolu] Les problèmes de déconnexions sauvages sur la beta BFBC2 pour neufbox

Recommended Posts

Bonjour à tous,

J'ai eu un problème récurrent: je ne pouvais pas rester connecté plus de 2-4 min sur un serveur de la beta. Après de nombreuses recherches, il s'avérait que c'était un problème de ports de jeu. Je les ai ouverts, rien n'a changé.

Pourquoi? Parce que Neuf-SFR font des modems à la **** pour le boulet lambda.

Je ne sais pas si je détiens la solution miracle mais voici comment on va devoir procéder pour jouer tranquillement:

Je mettrai la théorie à l'épreuve ce soir, mais à priori elle a fonctionné pour la bêta PS3.

=========================================================

Il faut tout d'abord créer une DMZ.

Très bien, mais c'est quoi une DMZ ?

Une DMZ est une zone démilitarisée qui existe sur de nombreux routeurs/modems. En l'activant, on crée une zone "sans armes" = on ouvre tous les ports.

La neufBox4 et uniquement la Neufbox4 ne dispose pas de DMZ, donc il faut les ouvrir manuellement.

Pour ouvrir manuellement l'ensemble des ports, il faut vous connecter au modem ( http://192.168.1.1), suivre les instructions pour pouvoir procéder aux règlages puis aller dans l'onglet réseau puis DHCP dans un premier temps. Une fois dans cet onglet vous cliquez sur l'icone réseau rouge à coté des identifiants MAC afin de faire reconnaitre votre PC. Notez l'adresse IP local qui va s'afficher (192.168.1.xx)

Ensuite, allez dans l'onglet NAT et ouvrez une "plage" en TCP et UDP et mettez y le montant maximum à savoir de 1 a 65535. La Case IP est à remplir avec l'IP donnée plus haut

Une fois l'opération terminée, redémarrez votre routeur via l'onglet administration/système.

/!\ATTENTION/!\: maintenant que tous les ports sont ouverts, vous êtes exposés aux dangers du net, c'est pourquoi il faudrait faire attention de bien vous protéger avec des pare-feux et autre anti-virus.

Avast est la meilleure alternative gratuite ;)

=========================================================

Maintenant que nous avons une IP sur le routeur, on va créer une IP fixe pour que l'ordinateur se connecte toujours sur la même adresse. Pour cela il va vous falloir également l'adresse DNS: cette adresse se trouve sur l'interface du routeur dans l'onglet DNS. Il faut noter les deux adresse séparées par un ;

Allez dans le panneau de configuration, ouvrez les connexions réseaux et partage ou connexions réseau sur XP et sélectionner l'icone du réseau local (sur 7, c'est l'icone RJ45 en dessous du globe si je me souviens bien). Faites un clic droit ou accéder aux propriétés. Choisissez le protocole IPv4 et faites propriété, remplissez les trous avec les infos précédentes (la passerelle est l'IP du routeur = 192.168.1.1). Fermez et redémarrez

NB: j'ai fais ce tuto de tête, je n'ai pas toutes les infos sous les yeux, j'éditerai le post si besoin est. Bon jeu :)

Share this post


Link to post
Share on other sites

J'ai bien galéré avant de les trouver :) j'espère que ca va marcher, sinon je vais m'ennuyer cette semaine :D Y 'a pas de raison la technique est éprouvée :)

Share this post


Link to post
Share on other sites

j'ai essayé ta méthode mais une fois que j'ai mis une adresse ip fixe, je ne peux plus naviguer sur internet, et quand je veux valider la plage de ports 1-65535, le logiciel de la neufbox me l'interdit au prétexte que je ne peux pas utiliser certains ports.

Share this post


Link to post
Share on other sites

je regarde ca ce soir, j'avais aussi des problèmes similaires. Je peux juste vous dire que la liste des ports à ouvrir est insuffisante. Je vais chercher.

EDIT: http://www.actuneuf.com/forums/viewtopic.php?pid=86924

Liste des ports réservés. J'attend vos résultats, je suis pas sur place avant ce soir voir demain à cause de la neige :)

EDIT2: http://www.jeuxvideo.com/forums/1-12324-81842-4-0-1-0-probleme-besoin-d-aide-svp.htm . Check le dernier message :) Il suffit de s'arreter avant les ports réservés et recommencer après :) GL HF config de m**** :P

Share this post


Link to post
Share on other sites

j'ai essayé en mettant les plages, mais cela met que les ports sont déjà utilisés même en mettant le numéro d'avant, j'ai toujours la même réponse : "ports déjà utilisés"

par contre certaines plages de ports se rentrent sans problemes

Share this post


Link to post
Share on other sites

Je ferai jamais sa même avec une très bon antivirus :rolleyes:

J'ai fais la soluce indiqué par rG.fr (le lien vers jv.com de juillet 2009) et ça MARCHe !!! J'ai fais une partie de 20min ça gère :P

Hop go miam et je joue toute la soirée.

Share this post


Link to post
Share on other sites

J'ai fais la soluce indiqué par rG.fr (le lien vers jv.com de juillet 2009) et ça MARCHe !!! J'ai fais une partie de 20min ça gère :P

Hop go miam et je joue toute la soirée.

Ca marche ok, mais tous tes ports sont ouverts, tu vas aller te balader sur le net, tu vas attraper toutes les saloperies de l'univers, dans une semaine on se reparlera après ton formatage :P

Share this post


Link to post
Share on other sites

Ca marche ok, mais tous tes ports sont ouverts, tu vas aller te balader sur le net, tu vas attraper toutes les saloperies de l'univers, dans une semaine on se reparlera après ton formatage :P

ça y'a des chances, surtout s'il met en plus avast en version gratuite :lol:

Share this post


Link to post
Share on other sites

Le risque est grand certes, mais on a pas vraiment le choix. Cette solution est temporaire, je vais en informer les personnes concernées sur le forum officiel.

J'aimerai connaitre vos versions de firmware qu'on se mette d'accord.

Merci de me les MP :)

@S.o.A: quand la plage entrée est fausse, le routeur t'indique quels osnt les ports réservés, tu as besoin d'une screen ? je suis en firmware NB4-MAIN-R2.0.14

Share this post


Link to post
Share on other sites

Le risque est grand certes, mais on a pas vraiment le choix. Cette solution est temporaire, je vais en informer les personnes concernées sur le forum officiel.

J'aimerai connaitre vos versions de firmware qu'on se mette d'accord.

Merci de me les MP :)

Kaspersky mais j'ai pas envie de tester si sa marche.

Share this post


Link to post
Share on other sites

Le risque est grand certes, mais on a pas vraiment le choix. Cette solution est temporaire, je vais en informer les personnes concernées sur le forum officiel.

J'aimerai connaitre vos versions de firmware qu'on se mette d'accord.

Merci de me les MP :)

@S.o.A: quand la plage entrée est fausse, le routeur t'indique quels osnt les ports réservés, tu as besoin d'une screen ? je suis en firmware NB4-MAIN-R2.0.14

tu peux en mettre une si tu veux (je verrais ci cela correspond à ce que j'essaye), mais je vais voir d'ici demain soir s'il n'y a pas du nouveau sur le forum anglais. certains ont essayé cette méthode et cela ne marche pas. et de plus je ne vais peut-être pas finalement tester cette méthode étant donné que je me sers de cet ordi pour aller sur le net. Mais c'est sympa d'avoir proposer.

Share this post


Link to post
Share on other sites

j'insiste,

ceux qui ont un réseau domestique et qui partagent leurs données entre PC (photos, etc...) évitez de créer une DMZ sur votre routeur...

cette solution est réservée à ceux qui hébergent des sites web, et qui savent (normalement) efficacement protéger un réseau public ouvert et vulnérable.

Et surtout si vous le faites, n'utilisez plus votre PC pour acheter sur le net avec votre carte bleue...

Share this post


Link to post
Share on other sites

Bonjour bonjour,

je suis nouveau, j'ai une neufbox et les nerfs à vifs ^^. Bon je suis loin mais alors TRES TRES loin d'être un AS en gestion de réseau, du coup je me balade de partout en essayant de trouver une solution à ce problème qui me pourri mes soirées :).

Je n'ai vraiment pas envie d'ouvrir tous les ports de mon routeur vue que je ne sais pas à quoi je m'expose, toutefois j'imagine qu'avec un Anti Virus correct et à jour (Avira dans mon cas) et les protections de W7 (64bit chez moi) je ne devrais pas trop avoir de soucis.

Tenter le diable n'étant pas dans mes prérogatives, je préfère rechercher indéfiniment d'autres solutions que celle présenté par rG.fr, et j'ais trouvé ceci :

627. Le lundi 1 février 2010 à 05:06, par darkmy

POUR CEUX QUI ON UN PROBLÈME DECO AU BOUT DE 5min avec neuf box de sfr.Voici ma solution.

Vous entrer dans votre modem(tapant 192.168.1.1 sur barre de navigaution)

Vous passer allez dans réseau et vous passez en mode bridge(si vous avez oubliez identifiant il est aussi la ba ******@neufpnp)

puis vous suivez ce guide: http://www.justneuf.com/wiki/index.php/Param%C3%A9trer_manuellement_une_connexion_ADSL_PPPOE

Source : http://www.battlefield.fr/blog/index.php/2010/01/29/276-feedback-sur-la-beta-de-battlefield-bad-company-2-sur-pc#co

Apparemment ça a marché pour certains, je vais essayer à mon tour. J'éspére ne pas avoir fais doublon sur une autre explication.

Bonne journée. A biental.

Share this post


Link to post
Share on other sites

Cette solution a en effet été invoqué sur d'autres forums, je n'ai pas trouvé nécessaire de la mentionner car il parait qu'elle crée d'autres problèmes. Je me renseignerai et mettrait à jour la fiche si aucune solution n'est trouvée d'ici à la sortie du jeu. Je demanderai un coup de patte des modos :)

Share this post


Link to post
Share on other sites

J'ai la même chose avec une livebox mini, enfin je préfère encore ne pas jouer plutôt que de transformer le pare-feu en passoire avec une DMZ. J'espère simplement qu'au pire, ça sera résolu pour la sortie du jeu.

Share this post


Link to post
Share on other sites

Bonjour tout le monde ;) je suis comme beaucoup de personnes proprietaire d'une NeufBox ( derniére génération pour ma part ) mais en fait y'a pas de solutions de trouvé à l'heure actuelle, je m'éxplique :

Comme tout le monde ( bon .. comme beaucoup on vas dire :rolleyes: ) je suis déconnecter toutes les 5 minutes de BFBC et je peux dire que c'est assez ... stressant voir même pire. Le probléme c'est qu'il n'y a PAS de solutions. Oui je sais il faut ouvrir tout les ports mais là ... à vos risques et perils ( et dieu sais qu'il sont grands les risques croyez moi ;) ).

Plus le temps passe et plus je me dis que malgré la mise à jour de DICE et malgré les centaines et les centaines de post que j'ai trouvé sur le net il n'y en à aucunes ( de solutions ) qui soit vraiment efficace car certaines manips entraine OBLIGATOIREMENT d'autres problémes.

Alors certains vont dire " oui mais c'est une Beta " oui je suis d'accord avec vous mais le probléme en fait et c'est là que sa fait mal c'est que on ne sais pas d'ou sa viens

La question qu'il faut se poser pour ceux qui ont se foutu probléme c'est .. vas t'il être reglé ? soit par SFR et/ou par DICE ? je sais pas mais à mon avis se probléme n'est pas prêt d'être reglé ou alors un miracle peut être ;)

PS : Bizarre que le forum indique que le probléme soit résolu parce que .. il n'y ai pas :(

Share this post


Link to post
Share on other sites

Moi franchement j'ai laissé tomber au bout de 2 jours de béta. J'attend avec impatience la démo sur PS3 pour jeudi. Ma clé que j'avais gagné au tirage au sort ne m'aura casiment pas servi.....

Share this post


Link to post
Share on other sites

http://forums.electronicarts.co.uk/battlefield-bad-company-2-pc-beta/884207-closed-beta-bug-status.html

voici les réponses concernant les différents bugs et surtout celui pour les déco.

"Connection to server has been lost"

* This one is tricky. We have no solution yet."

ils n'ont pas de solution pour ce soir, donc wait and see :huh:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this